Back to overview
Downtime
Servers are down
Oct 11 at 11:09pm HDT
Affected services
Website
Blacklist
Resolved
Oct 11 at 11:22pm HDT
As far as we know the problem has been fixed.
Affected services
Updated
Oct 11 at 11:15pm HDT
We have preemptively started our servers and are watching for further developments.
Affected services
Created
Oct 11 at 11:09pm HDT
We have noticed that our servers are unavailable, we are investigating the cause.
Affected services